mariadb ketika import error gini Row size too large (> 8126) solusinya ?

Solusi Ke 1 : The error message Row size too large (> 8126). Changing some columns to TEXT or BLOB may help. In current row format, BLOB prefix of 0 bytes is stored inline. means that the row size of a table in MySQL is larger than the maximum row size of 8126 bytes. This can happen if the table has a lot of columns, or if the columns are of a data type that takes up a lot of space, such as VARCHAR or TEXT. To fix this error, you can try the following: Change some columns to TEXT or BLOB.&nb ...

View More
  Dibaca 3431 kali

you may need to install the HTML::Entities module

  I managed to sort it myself. As I was using the server provided by my university I had no access to install the required module (HTML::Entities). I decided to then set up the required module on my own Apache web server on a virtual machine and managed to get it working this way after sorting out some syntax/spelling errors. The way I installed the HTML::Entities module was through the synaptic package manager, just by searching libhtml-parser-perl the module was found and installed. I r ...

View More
  Dibaca 2588 kali

restart ubuntu nginx not running

sudo systemctl enable nginx.service // try a reboot sudo reboot // check status of nginx sudo systemctl status nginx.service // can start it with this to see if it's running properly sudo systemctl start nginx.service ...

View More
  Dibaca 1343 kali

Ubuntu Cannot Ping Domain

Create a file called /etc/resolv.conf write fill in the contents: nameserver For example if your want to use googles dns-service: nameserver 8.8.8.8 nameserver 8.8.4.4 This is likely caused by DHCP configuration when you first installed Ubuntu. Try this 3-step process to handle this auto configuration issue. First Edit your interface configuration, which is located in: /etc/network/interfaces Add this line below iface lo inet loopback: dns-nameservers yourdns youraltdns As ...

View More
  Dibaca 1858 kali

How can I disable MySQL Strict Mode?

This is enabled by default, but you can disable it in one of a couple ways. First, verify which mode(s) MYSQL is running with: $ mysql -u root -p -e "SHOW VARIABLES LIKE 'sql_mode';" You'll need to replace root with whatever username has superuser permissions on your server (but, it's usually just root). You'll also be prompted for the password. This will print out something like this (but much prettier): sql_mode: ONLY_FULL_GROUP_BY,STRICT_TRANS_TABLES,NO_ZERO_IN_DATE,NO_ZERO_D ...

View More
  Dibaca 2559 kali

PHP Session not Saving

Your session directory (probably /tmp/) is not writable. Check with session_save_path() if it is writable. if (!is_writable(session_save_path())) { echo 'Session path "'.session_save_path().'" is not writable for PHP!'; } ...

View More
  Dibaca 2221 kali

Force Showing all errors and warnings in PHP

You can turn it on in the script: error_reporting(E_ALL); ini_set('display_errors', 1); ...

View More
  Dibaca 1421 kali

MySQL alter table add column with primary key

ALTER TABLE t_dataDROP PRIMARY KEY,ADD COLUMN id INT NOT NULL AUTO_INCREMENT FIRST,ADD PRIMARY KEY (id);   if not a primary key ALTER TABLE t_dataADD COLUMN id INT NOT NULL AUTO_INCREMENT FIRST,ADD PRIMARY KEY (id); ...

View More
  Dibaca 1447 kali